Yomoni - Blocked

Minor incident Wealth Product Tier B Connectors Yomoni
2025-05-07 09:26 CEST · 8 months, 2 weeks, 4 days, 1 hour

Updates

Resolved

The issue has now been resolved.

Thank you, Yomoni, for your collaboration in resolving this matter and enabling your clients to use OpenBanking with Powens. We apologize for any inconvenience this may have caused and appreciate your patience throughout the process.

January 20, 2026 · 09:19 CET
Investigating

We are currently in talks to determine the best course of action to avoid being blocked.

May 7, 2025 · 09:26 CEST

← Back