Qonto PSD2 - Major outage

Major incident Bank Product Tier A Connectors Qonto
2025-05-09 15:49 CEST · 2 weeks, 4 days, 23 hours, 54 minutes

Updates

Resolved

The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

May 28, 2025 · 15:43 CEST
Monitoring

It seems, Qonto has fixed the problem. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

May 26, 2025 · 09:50 CEST
Issue

We are actively investigating an issue. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.

May 14, 2025 · 15:49 CEST

← Back