Allianz - Blocked

Minor incident Wealth Product Tier B Connectors Allianz
2024-12-01 14:55 CET · 11 months, 2 days, 23 hours, 41 minutes

Updates

Resolved

Allianz has finally unblocked us. Thank you for your patience.

October 30, 2025 · 13:58 CET
Issue

We are currently in talks to determine the best course of action.

May 16, 2025 · 14:55 CEST

← Back