Banque Populaire - Outage

Major incident Wealth Product Tier A Connectors Banque Populaire
2025-05-20 17:28 CEST · 1 week, 2 days, 15 hours, 57 minutes

Updates

Resolved

Resolved - The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

May 30, 2025 · 09:25 CEST
Investigating

Resolved - The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

May 30, 2025 · 09:24 CEST
Investigating

Our investigation is ongoing. We are making progress in understanding the issue and are exploring potential solutions. We appreciate your continued patience and will share another update shortly.

May 23, 2025 · 10:58 CEST
Update

We have identified the root cause of the issue. Our team is now working on a resolution. We will keep you informed of any significant developments.

May 22, 2025 · 09:12 CEST
Issue

Our investigation is ongoing. We are making progress in understanding the issue and are exploring potential solutions. We appreciate your continued patience and will share another update shortly.

May 20, 2025 · 17:28 CEST

← Back