Banque Populaire - Major Outage
Major incident
Wealth Product
Tier A Connectors
Banque Populaire
2025-06-04 14:15 CEST
· 1 day, 18 hours, 48 minutes
Updates
Resolved
June 6, 2025 · 09:04 CEST
The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.
Issue
June 4, 2025 · 14:15 CEST
We are actively investigating an issue. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.
← Back