BNP Paribas - Major Outage

Major incident Wealth Product Tier A Connectors BNP Paribas
2025-07-18 10:26 CEST · 4 days, 22 hours, 56 minutes

Updates

Resolved

The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

July 23, 2025 · 09:21 CEST
Issue

We have identified the root cause of the issue. Our team is now working on a resolution.

July 18, 2025 · 10:26 CEST

← Back