WeSave - Major outage
Major incident
Wealth Product
Tier B Connectors
WeSave
2025-08-14 09:24 CEST
· 4 days, 2 hours, 25 minutes
Updates
Resolved
August 18, 2025 · 11:49 CEST
The problem seems to have been solved by WeSave, and we are monitoring the situation closely. Thank you for your understanding.
Issue
August 14, 2025 · 09:24 CEST
Investigating - We are actively investigating an issue. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.
← Back