Crédit Agricole - Minor Outage

Minor incident Bank Product Tier A Connectors Crédit Agricole
2025-08-21 10:00 CEST · 23 hours, 9 minutes

Updates

Resolved

The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.

August 22, 2025 · 09:09 CEST
Issue

Crédit Agricole has identified a problem. Its team is currently working to resolve it. We will keep you informed of any significant developments.

August 21, 2025 · 10:00 CEST

← Back