Floabank - Major outage
Major incident
Wealth Product
Tier B Connectors
Floa Bank
2025-10-21 15:56 CEST
· 18 hours, 49 minutes
Updates
Resolved
October 22, 2025 · 10:45 CEST
Floabank has made changes to its customer area on its new Floa mobile application. We do not currently support this type of application, and the service will be unavailable on Floa for an indefinite period. Thank you for your understanding.
Issue
October 21, 2025 · 15:56 CEST
We are actively investigating an issue. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.
← Back
Connector Availability