LCL PSD2 - Minor outage
Minor incident
Bank Product
Tier B Connectors
LCL
2026-01-26 14:55 CET
· 3 days, 19 hours, 26 minutes
Updates
Resolved
January 30, 2026 · 10:20 CET
The bank has rolled back the changes and we will monitor the situation. Sorry for the inconvenience.
Issue
January 26, 2026 · 14:55 CET
We are actively investigating an issue with retrieving accounts informations. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.
← Back
Connector Availability