Revolut AIS / PIS - Android outage
Minor incident
Bank Product
Tier A Connectors
Revolut
2026-04-12 17:07 CEST
· 1 week, 5 days, 23 minutes
Updates
Resolved
April 24, 2026 · 17:29 CEST
The issue has been resolved. We apologize for any inconvenience this may have caused and appreciate your patience throughout this process.
Update
April 23, 2026 · 10:11 CEST
A fix has been identify. We are working on it.
Thank you for your patience.
Issue
April 21, 2026 · 17:07 CEST
We are actively investigating an issue on the bank side. Our team is working to identify the root cause. Thank you for your patience.
← Back
Connector Availability