Nalo - Service interruption
Major incident
Wealth Product
Tier A Connectors
Nalo
2026-05-06 15:23 CEST
· 2 weeks, 4 days, 9 hours, 29 minutes
Updates
Investigating
May 11, 2026 · 17:29 CEST
Nalo has recently overhauled its authentication system, which has resulted in a temporary compatibility issue with Powens.
We are in direct contact with their technical team, who confirmed that implementing OAuth authentication is now on their development roadmap. While they haven’t provided a specific timeline yet, this transition will ultimately ensure a more secure and stable connection.
We are monitoring the situation closely and will update you as soon as more information becomes available.
Issue
May 6, 2026 · 15:23 CEST
We are actively investigating an issue. Our team is working to identify the root cause, and we will provide updates as soon as more information is available. Thank you for your patience.
← Back
Connector Availability