Revolut PIS - Major outage

Major incident Pay by Bank Revolut PIS
2026-09-01 17:47 CEST · 20 hours, 21 minutes

Updates

Resolved

The issue has been solved, all instant PIS are now working well

September 2, 2026 · 14:09 CEST
Issue

Revolut Instant PIS are staying in “Pending” status. We are investigating the issue but it seems to be on Revolut’s side

September 1, 2026 · 17:47 CEST

← Back