AmericanExpress - Major Outage
Major incident
Transactions
Tier B Connectors
American Express
2026-09-01 14:04 CEST
· 2 weeks, 19 hours, 28 minutes
Updates
Resolved
September 16, 2026 · 09:31 CEST
This issue is now resolved and all services are operating normally. We apologize for the inconvenience and thank you for your patience.
Issue
September 11, 2026 · 14:04 CEST
We are actively investigating an issue impacting new connection. Our team is working on a fix and will update you shortly. Thank you for your patience.
← Back
Connector Availability